Installing Foglight Agent Manager to Raspberry Pi

Can Foglight run on a Raspberry Pi running Linux? This blog answers the question.

Interestingly, I've been asked more than once recently if the Foglight Agent Manager can be installed on a Raspberry Pi (version 3) running Raspbian. One of the main use cases is to have Agent Managers in different network segments and to use inexpensive hardware to do that. 

After a bit of testing, the answer is, unfortunately, no.

The Raspberry Pi version 3 runs an ARM based processor (armv71 to be precise.) Looking up the specs, it's a 32-bit processor. So far so good. We have a 32-bit Linux installer for the Foglight Agent Manager. I loaded that cartridge into my Foglight Management Server and then downloaded the installer to the Pi.

I set the installer.bin file to executable, then tried to run it.

The error I get is: -bash: ./FglAM-5_8_5_5-linux-ia32.bin: cannot execute binary file: Exec format error

I took a few more steps for completeness, but after running "file" on the installer (file ./FglAM-5_8_5_5-linux-ia32.bin), I got:

./FglAM-5_8_5_5-linux-ia32.bin: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux.so.2, for GNU/Linux 2.6.9, not stripped

I ran "file /bin/bash", and got:

/bin/bash: ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, for GNU/Linux 2.6.32, BuildID[sha1]=3e92423821f3325f8cb0ec5d918a7a1c76bbd72c, stripped

The Foglight Agent Manager installer is compiled for Intel x86 while the Raspberry Pi is an ARM processor. So that's that.

But wait, there's more. In an upcoming blog, I'm going to show what we can do as far as monitoring the Raspberry Pi with Foglight.

 

About the Author
Darren Mallette
I am a senior systems consultant specializing in performance monitoring for virtualization, databases, applications and end user experience. I've been in the IT world for over 20 years, with experience...