Setting up Foglight when SQL Server wants SSL

A customer recently had this error message when trying to monitor a new SQL Server instance:

Reason : [Foglight][SQLServer JDBC Driver]The SQL Server login requires an SSL connection.

They didn't want to disable the requirement for an SSL connection, so we followed the following steps. Thanks to  for the tip!

Start by selecting the option to discover multiple SQL Server instances:

Select the Foglight Agent Manager you wish to run the agent from, and validate it.

Select Add Instances and Add Manually.

Enter the host\instance name in the popup window. Next, select the instance, and set credentials.

Set the SSL Connection pulldown to mandatory. Enter DB credentials and other options (OS/PI) and click Monitor.

About the Author
Darren Mallette
I am a senior systems consultant specializing in performance monitoring for virtualization, databases, applications and end user experience. I've been in the IT world for over 20 years, with experience...
  • How does this make a strong use case for customers?

  • Hi,

    we have SQL Server 2016 Enterprise and on it we have SSL enabled (we force connections to use SSL). When we adding SQL Server to Foglight monitoring we get error (SSL Connection is set to mandatory).

    If we disable SSL on SQL Server then monitoring works (also we need to change SSL connection back). We have also opened case on Dell Support about this for almost 6 months.

    Did you maybe noticed similar problems?

    Thank you for help.

    Regards,

    Erik

  • Hi Erik,

    I'm having the exact same issue regarding ssl, sql 2016 and curve encryption issues - did you ever fix this?

    KR,

    Jonathan