Active Roles

Get-QADUser returns blank values

In the process of upgrading our v6.9 to the latest version but there is a burning issue for which our Operations team is looking for a report. The requirement is to gather the list of all user accounts in AD with their EmployeeIDReference and Division (of which EmployeeIDReference is a virtual attribute. Division is exposed and available using AD PowerShell Modules too)

If I run

Get-QADUser <identity> -IncludedProperties EmployeeIDReference,Division,samAccountName | Select EmployeeIDReference,Division,samAccountName 

It works fine, displays the table correctly.

But If I run 

Get-QADUser -sizeLimit 0 -IncludedProperties EmployeeIDReference,Division,samAccountName | Select EmployeeIDReference,Division,samAccountName

I get all blank attributes for everything except samAccountName.

If I run Get-QADUser -sizeLimit 0 -IncludeAllProperties | Select EmployeeIDReference,Division,samAccountName

it takes forever to run (as each user has about ~200 attributes) but gets there eventually and so is not really desirable. I had a look at the half built data and the info we were looking for is there.

(P.S.: I've already run the connect-qadservice <Servername> -proxy at the beginning>

 

Any thoughts or alternate suggestions?

Parents
No Data
Reply Children
No Data