Identity Manager

You have no insert permission for this object.


I would like to pass the creation of internals employees through the validation of HR. I already implemented this process so when a manager declare a new joiner, this one is created with IsInactive=True and it goes to False when the HR team approve the creation.

It works perfectly yesterday but when I wanted to do a test today, I get the error below : You have no insert permission for this object. Any idea on what could be the problem ? knowing that I can create externals users with no problem

for information, when the manager specify that the user will be internal (i.e. IsInactive=True), the departure date is set to today and cannot be changed which is logic in my sens. 

  • Hello,

    We would need more information to provide assistance with this. For example, where is the error message appearing? I assume the new Employees are being created in the web portal?

    What is the version?

    Are you testing with the same use that was successful previously?

    I would suggest to open a service request with Support to better troubleshoot this type of issue and provide the specifics, ie logs.

  • Hi Trevor, Yes it happens when a new employee is being created in the web portal and I'am using the v8.0.0.36

    to create internal employees with an inactive identity, i am using the emplate below :

    if (String.IsNullOrEmpty($ImportSource$)) and ($CustomProperty01$ = "CDI" or   $CustomProperty01$ = "Intern") then

    value = true

    Else value = false

    end if

  • You could try with the same credentials in Object Browser. I just assume that you have not configured the permissions for isInactive properly.
  • Yes it works in the Object Browser as Administrator. On the other hand, I added the View/Edit/Insert permissions for the group CCCEditPermissons on the attribute IsInactive but still get the same error. Do you think that I have to configure further permissions ?
  • MAS77 said:


    It works perfectly yesterday but when I wanted to do a test today, I get the error below

    Maybe you have changed your permissions wrong.

    What do you mean with Administrator from the last post and Manager from the initial post? Testing permissions should always be done with the same user and the same credentials and authorization. 

    Maybe not the property isInactive causes the problem, but another property.