Is authentication method workflow step mandatory for resetting password workflow?

Hi

I am using password manager 5.8.2.

I have a requirement that a helpdesk user can reset password for employee without any authentication.

I have some employee who does not need to create a QA profile. If those employees call to the help desk for reset the password, help desk people will reset the password for those employees

So, for the reset password workflow we do not need any authentication method. 

We have only two workflow steps for resetting password

  1. Reset password in active directory
  2. Reset workflow if error occurs

 

Now, I am testing this scenario and getting error

“User profile doesn't have helpdesk question at index 0 for the helpdesk authentication”

“Select a method to authenticate.”

 

Is authentication method mandatory for resetting password workflow? If not, can you please guide me how can I overcome this error.

Thanks in advance.

Parents
No Data
Reply
  • Thanks Stephen for your clear and detail comment. I have followed your steps however still got the same error.

    As you said you already tested in your lab environment that make me feel do I missing something or what is wrong with my set up and found your set up and my set up is not exactly similar.

    I think I understand what is the problem but not sure it is a bug or it is the default behaviour by the system.

    Problem statement: When a Helpdesk user logs into the Helpdesk site and selects a user to manage, the workflow options that are presented are based on the Management policies that the helpdesk user is included in the scope for. Ideally, the workflow options presented to the helpdesk user should be those that apply to the target user (based on the management policies user scope)

     

    furthermore, if a single helpdesk user is included within the helpdesk scope of multiple management policies, the workflows that are presented to them for a target user seem to be based on the first management policy for which the helpdesk user is included in the scope.

    I think here is my problem. I have multiple management policy however helpdesk user scope is same that means same helpdesk person have to all the management policy.
    For Example

    I have two Management Policies MP1 and MP2 and I have helpdesk User (HU) who can manage MP1 and MP2. 
    In MP1 user scope I have one User MPU1 and in MP2 user scope I have one user MPU2.

    Now, MP1 have QA and helpdesk profile so MPU1 need to set up profile and HU helpdesk user can reset MPU1 password (no issue here)

    However MP2 does not have helpdesk question so MPU2 user does not need to set up helpdesk question and answer. when Helpdesk User (HU) tries to 
    reset the password for MPU2 then I got the error and the system says User need to set up helpdesk question and answer and I think obeying the MP1 management policy
    rather than MP2.

    Can you please help me out whether it is a bug or a default behaviour. thanks in advance

Children
No Data