Install 11.2 for pure 64 instead of upgrade. How to retrieve all config settings from prior 10.0 installation?

Hi,

According to documentation, there is no path from a hybrid linux server to a pure 64 server. So, following the upgrade, you backup the NVDB and then save the current 10.0 server and then install the new 11.2 pure server. Once this is done. Is there a way to easily retrieve all the selection sets, job definitions, etc from the old instance and copy to the new one other than copying screen shots from webui of prior instance?

 

Thanks,

Henry

  • Hi Henry,

    The procedure would have to be done via the following method.
    1. Backup current NetVault DB
    2. Upgrade to Hybrid NetVault Server 11.2
    3. Backup NVDB again with 11.2 Hybrid
    4. Uninstall Hybrid Linux Server 11.2
    5. Install NV 11.2 Pure 64 build
    6. Restore NVDB using the NVDB Restore Procedure from the NetVault Built-In Plugin Users Guide.

     

    Note: I would proceed with the normal instructions for doing the NVDB restore,  but I would advise against restoring the "Configuration."

    This will require you to enter any thing that may have been configured such as "Network Manager, Firewall, Transfer Buffer and Block sizes, etc..."

    So just be sure to take screen shots of those if you have them set.

     

    I hope this helps, please let me know if you have any questions.

  • In reply to Andre.Cooley:

    Hi Andre,

    Thanks for the tip - will try it out.
  • In reply to hk-vndr:

    Hi Andre,
    I think you are missing something. The NVDB backed up in step 3 is distinct from the db that is newly installed in step 5, so the restore job created in step 6 has no saveset from which to choose. Is this process similar to mysql where you can simply copy the db tree recursively into the new location? Will shutting down the instance and copying over the old backed up nvdb in $(NETVAULT)/db to the new location then starting up allow one to restore the nvdb?

    Have just confirmed that there is a checksum involved that precludes copying over the old db tree from one instance of the same version (11.2) to another instance.

    Thanks,
    Henry

  • In reply to hk-vndr:

    Correct, you would have a new DB in with the fresh install, however, you would have backed up the DB on 11.2 in Step 4. The primary aspects of the 64bit build are not the files essential for the DB of NetVault, so you would restore this from the backup you did when you first upgrade to 11.2 Hybrid.
  • In reply to Andre.Cooley:

    But I'm still missing something - each respective backup is not visible to the fresh install, unless you scan in the tapes or smart disk, in my case, to recover the indices first. Then you can do the nvdb restore which I think worked but now I cannot get back into the web ui using the admin pwd.
  • In reply to hk-vndr:

    If you have tape, then you would have to scan in those tapes first, this is why it is recommended to just have one tape readily available with the NVDB.
    Then, once that tape is scanned in, you do the NVDB restore of the components mentioned, but not Keys or Configuration.
    If you scan all your tapes it will rebuild your media index/db - but the NVDB restore will also restore this.
    If you let all the media scan in, you could also just then restore only the Schedule DB at that point.
    As far as not being able to log in, I would first try to clear your browser cache/history...etc..., then try to login.
  • In reply to Andre.Cooley:

    I did scan in the smartdisk on the network and then performed the NVDB restore, I omitted the configuration but added the keys so I think this is why I cannot log in. I have the NETVAULTCLI* env vars sets and cannot issue any CLI successfully either. May have to go back to the hybrid and try the restore again.

    All my CLI result in:

    # nvclient -list
    CliInitSession FAILED