Cisco Configuration Backup via Foglight NMS failing

Hi, I'm using Foglight NMS 6.0.20843 with a number of routers running Cisco IOS. Foglight is able to access the routers via SNMP (RO access), and is currently monitoring CPU and memory usage. However, it's unable to to backup their configurations. Configuration Backup in Settings -> Verify Monitoring Status always shows ERROR_FUNCTION_FAILED for all of the monitored devices. The devices are able to connect to the Foglight TFTP server manually (copy run tftp), and are able to successfully upload files, but I'm assuming the files are getting stored in the Foglight database rather than in the filesystem, as they don't appear in a search on the server. I confirmed that Foglight is listening on the TFTPd port on the server via TCPView. Does Foglight need read-write SNMP access to backup IOS devices' configurations? Is there logging occurring somewhere that might help troubleshoot, and/or more documentation than the "Cisco Config" page in the help file? Thanks!

  • Does it have the correct telnet credentials? You might check manage credentials and make sure it has the right telnet credentials in there.

    Mike

  • I didn't include any telnet credentials, as I expected the software to be using IOS's MIBs for backup. Adding credentials fixed it, though. Thanks!

  • Hello,

    I have problem with backup of cisco switch. The same error as . I added telnet/ssh credentials and I have R/W snmp credentials configured. I can ssh to the device using "tools" menu and do snmp walk.

    But when I run go Live it still gives me error_function_failed for backup status.

    The device allows only SSH connection and not Telnet.

    Please advise

    Alex

  • Hi Alex,

    For Cisco devices, we utliize the R/W SNMP credential, to pull the configuration backup. We shouldn't need Telnet/SSH credentials.

    Can you log onto the Cisco device CLI, and try the following please:

    copy running-config tftp (make sure you input the IP address of the agent that is monitoring this system)


    Is this command successful?

  • Yes, copy tftp worked.

  • Hello,

    I'm currently installing Foglight NMS on a customer. We got everything set up as usual.

    I have Network traffic flow setup on all of them.

    Out of the 36 cisco routers i configured, only one of them gets the Configuration Backup.

    the other 35 fail with ERROR_FUNCTION_FAILED as mentioned in this post.

    SNMP and telnet credencials are working. there is no SSH usage.

    I've gone throught the firewall and all is OK. how can i detect why 35 arent pulling the backup config? can it be a firmware issue?

    Most of the 35 devices that don't obtain the backup are 2900 series with 15.x firmware version.

    Would love some feedback

    Cheers,

    Gon+ºalo

  • Seems what's keeping Foglight NMS from retreiving configuration backup from several router devices is the usage of 'TACACS+'.

    Most of the routers are using Cisco IOS Command 'aaa new-model'. If we remove the config, NMS pulls the information quickly simply by doing a 'Go Live'.

    Cisco TACACS+ link:

    http://www.cisco.com/en/US/docs/ios/11_3/security/configuration/guide/sctcacs.html

    Cheers,

    Gon+ºalo

  • I have problem with Cisco switch backup. The same error as. I have added telnet / ssh credentials and I have configured R / W snmp credentials. I can ssh to the device using the "tools" menu and do the snmp walk. www.braindumps4it.com/braindumps-300-180.html

    But when I run go live it still gives me error_function_failed for the backup state.

    The device only allows SSH and non-Telnet connection.
  • I really enjoyed reading your article. I found this as an informative and interesting post, so i think it is very useful and knowledgeable. I would like to thank you for the effort you have made in writing this article. ***Information has been Flagged as Spam and has been Deleted. if you feel that the information deleted is not Spam please contact us or Reply to the Private message Sent. ****

  • copy running-config tftp (make sure you input the IP address of the agent that is monitoring this system) do this and you re good to go and for help regarding firefox related issues you can contact the     ***Information has been Flagged as Spam and has been Deleted. if you feel that the information deleted is not Spam please contact us or Reply to the Private message Sent. ****

  • Thanks for the wonderful post. It is a very informative and interesting post. We get to know about this topic. Configuration problem occurs when people work on the system.

    ***Information has been Flagged as Spam and has been Deleted. if you feel that the information deleted is not Spam please contact us or Reply to the Private message Sent. ****

  • In reply to marringt:

    Yes,it is absolutely correct.I had tried it by myself and happy to get the effective solutions.Thanx for sharing with all! 

    ***Information has been Flagged as Spam and has been Deleted. if you feel that the information deleted is not Spam please contact us or Reply to the Private message Sent. ****