ARS WI site creation failed: The specified path already exists.

Hello,

I just upgraded my environment to 7.1 in Dev.

I'm trying to configure a custom web interface on a server that had 6.9 installed.

I'm importing the custom interface from an export. It seems to work fine from a new servers.

Although when trying to import to a server that had 6.9 i get the following error.

Does anyone know where i might look to delete this path?

I've made sure after the uninstall of 6.9 to remove the virtual websites but cannot see any references to the site i'm attempting to import.

Any help is appreciated.

Thank you,

Lu

 

  • Hey Lu,

    When looking in IIS under 'Default Website', have all of the older sites been deleted?

    Also, it is not really a supported/recommended configuration to import a 6.9 site into a 7.x instance due to the site redesigns. It will accept the import, however there is a moderate chance you will run into issues down the road.
  • In reply to Nick.Vance:

    Nick,

    Thanks for the reply.

    Yes i've confirmed that the older sites are gone in IIS. Which is why I'm stumped.

    Thanks for the advice on the imports. I will probably recreate them from scratch knowing there maybe some issues.

    Although I would like to keep the original site names but get the same file path already exisit error when trying to rename.

    Thanks for the help and advice, Lu

    See the log below...

    ____________________________________________________________________________________________

    [2017-10-10T15:43:57.016] [<not set>]: [ArsBaseCommand.ProcessRecord]: begin...

    [2017-10-10T15:43:57.016] [<not set>]: [NewARWebSiteCommand.Execute]: begin...

    [2017-10-10T15:43:57.016] [<not set>]: [NewWebSiteAction.Execute]: Start

    [2017-10-10T15:43:57.016] [<not set>]: [NewWebSiteAction.Execute]: Parameters:
    ValidateOnly = 'True'
    ConfigSelection = 'ValidateOnly'
    Template = ''
    Configuration = ''
    ImportConfigurationFromObject = ''
    ImportConfigurationFromFile = ''
    ImportConfigurationFromString = ''
    IISWebSite = 'Default Web Site'
    WebApplicationAlias = 'ARSAdmin'
    ServiceSelection = ''
    ServiceName = ''
    ConfigurationName = ''
    ForceCreateDefaultARWebSite = 'False'

    [2017-10-10T15:43:57.017] [<not set>]: [NewWebSiteAction.Validate]: begin...

    [2017-10-10T15:43:57.017] [<not set>]: [ChangeWebSiteAction.InternalValidate]: begin...

    [2017-10-10T15:43:57.017] [<not set>]: [WebApplicationManager.GetServiceSelection]: Start...

    [2017-10-10T15:43:57.018] [<not set>]: [WebApplicationManager.GetServiceSelection]: End. Service selection 'LocalService', Service name ''

    [2017-10-10T15:43:57.082] [<not set>]: [ChangeWebSiteAction.CheckIISWebSite]: begin...

    [2017-10-10T15:43:57.122] [<not set>]: [ChangeWebSiteAction.CheckIISWebSite]: end.

    [2017-10-10T15:43:57.122] [<not set>]: [WebApplicationManager.GetARWebSites]: begin... iisSiteName = 'Default Web Site', webApplicationAlias = 'ARSAdmin', configurationName = ''

    [2017-10-10T15:43:57.155] [<not set>]: [WebApplicationManager.GetARWebSites]: end. Count = 0

    [2017-10-10T15:43:57.155] [<not set>]: [ChangeWebSiteAction.InternalValidate]: end.

    [2017-10-10T15:43:57.155] [<not set>]: [NewWebSiteAction.Validate]: end.

    [2017-10-10T15:43:57.155] [<not set>]: [NewWebSiteAction.Execute]: Validation ends.

    [2017-10-10T15:43:57.155] [<not set>]: [ArsBaseCommand.WriteValidationErrors]: begin...

    [2017-10-10T15:43:57.155] [<not set>]: [ArsBaseCommand.WriteValidationErrors]: end.

    [2017-10-10T15:43:57.155] [<not set>]: [NewARWebSiteCommand.Execute]: Output object:

    [2017-10-10T15:43:57.155] [<not set>]: IISWebSite: Default Web Site
    WebApplicationAlias: ARSAdmin
    ConfigurationName:
    Version: ActiveRoles71
    ServiceSelection: LocalService
    ServiceName:

    [2017-10-10T15:43:57.155] [<not set>]: [NewARWebSiteCommand.Execute]: end.

    [2017-10-10T15:43:57.155] [<not set>]: [ArsBaseCommand.ProcessRecord]: end.

    [2017-10-10T15:44:04.637] [<not set>]: [ArsBaseCommand.ProcessRecord]: begin...

    [2017-10-10T15:44:04.637] [<not set>]: [NewARWebSiteCommand.Execute]: begin...

    [2017-10-10T15:44:04.638] [<not set>]: [NewWebSiteAction.Execute]: Start

    [2017-10-10T15:44:04.638] [<not set>]: [NewWebSiteAction.Execute]: Parameters:
    ValidateOnly = 'True'
    ConfigSelection = 'ValidateOnly'
    Template = 'Administrators'
    Configuration = ''
    ImportConfigurationFromObject = ''
    ImportConfigurationFromFile = ''
    ImportConfigurationFromString = ''
    IISWebSite = 'Default Web Site'
    WebApplicationAlias = 'ARSAdmin'
    ServiceSelection = ''
    ServiceName = ''
    ConfigurationName = 'ARSAdmin'
    ForceCreateDefaultARWebSite = 'False'

    [2017-10-10T15:44:04.638] [<not set>]: [NewWebSiteAction.Validate]: begin...

    [2017-10-10T15:44:04.638] [<not set>]: [ChangeWebSiteAction.InternalValidate]: begin...

    [2017-10-10T15:44:04.638] [<not set>]: [WebApplicationManager.GetServiceSelection]: Start...

    [2017-10-10T15:44:04.639] [<not set>]: [WebApplicationManager.GetServiceSelection]: End. Service selection 'LocalService', Service name ''

    [2017-10-10T15:44:04.698] [<not set>]: [ChangeWebSiteAction.CheckIISWebSite]: begin...

    [2017-10-10T15:44:04.735] [<not set>]: [ChangeWebSiteAction.CheckIISWebSite]: end.

    [2017-10-10T15:44:04.735] [<not set>]: [WebApplicationManager.GetARWebSites]: begin... iisSiteName = 'Default Web Site', webApplicationAlias = 'ARSAdmin', configurationName = ''

    [2017-10-10T15:44:04.769] [<not set>]: [WebApplicationManager.GetARWebSites]: end. Count = 0

    [2017-10-10T15:44:04.769] [<not set>]: [ConfigurationStorageAD.GetConfiguration]: Start. Configuration name 'ARSAdmin', Version 'ActiveRoles71', require full data 'False'

    [2017-10-10T15:44:04.947] [<not set>]: [ConfigurationStorageAD.GetConfiguration]: Configuration 'ARSAdmin' has been found.

    [2017-10-10T15:44:04.948] [<not set>]: [Error] [ChangeWebSiteAction.InternalValidate]: Parameter: 'ConfigurationName'. Error: Unable to use configuration name 'ARSAdmin' for new configuration because a configuration with this name already exists.

    [2017-10-10T15:44:04.949] [<not set>]: [Error] [ArsConfigActionHelper.ProcessError]: Message 'Unable to use configuration name 'ARSAdmin' for new configuration because a configuration with this name already exists.';
    Parameter name 'ConfigurationName';
    Stack trace:
    at ActiveRoles.Web.Configuration.ChangeWebSiteAction.ValidateNotExistingConfiguration(Boolean validateOnly, String configurationName, IWebSiteConfigurationStorage configurationStorage)
    at ActiveRoles.Web.Configuration.ChangeWebSiteAction.InternalValidate(NewWebSiteParameters parameters, ARWebSite& site, IWebSiteConfigurationStorage& configurationStorage, Boolean isWebAppCreation)

    [2017-10-10T15:44:04.949] [<not set>]: [ChangeWebSiteAction.InternalValidate]: end.

    [2017-10-10T15:44:04.949] [<not set>]: [NewWebSiteAction.Validate]: end.

    [2017-10-10T15:44:04.949] [<not set>]: [NewWebSiteAction.Execute]: Validation ends.

    [2017-10-10T15:44:04.949] [<not set>]: [ArsBaseCommand.WriteValidationErrors]: begin...

    [2017-10-10T15:44:04.949] [<not set>]: [ArsBaseCommand.WriteValidationErrors]: Validation exception: Unable to use configuration name 'ARSAdmin' for new configuration because a configuration with this name already exists.

    [2017-10-10T15:44:04.949] [<not set>]: [ArsBaseCommand.WriteValidationErrors]: end.

    [2017-10-10T15:44:04.949] [<not set>]: [NewARWebSiteCommand.Execute]: Output object:

    [2017-10-10T15:44:04.949] [<not set>]: IISWebSite: Default Web Site
    WebApplicationAlias: ARSAdmin
    ConfigurationName:
    Version: ActiveRoles71
    ServiceSelection: LocalService
    ServiceName:

    [2017-10-10T15:44:04.949] [<not set>]: [NewARWebSiteCommand.Execute]: end.

    [2017-10-10T15:44:04.949] [<not set>]: [ArsBaseCommand.ProcessRecord]: end.

    [2017-10-10T15:44:11.545] [<not set>]: [ArsBaseCommand.ProcessRecord]: begin...

    [2017-10-10T15:44:11.545] [<not set>]: [NewARWebSiteCommand.Execute]: begin...

    [2017-10-10T15:44:11.545] [<not set>]: [NewWebSiteAction.Execute]: Start

    [2017-10-10T15:44:11.545] [<not set>]: [NewWebSiteAction.Execute]: Parameters:
    ValidateOnly = 'True'
    ConfigSelection = 'ValidateOnly'
    Template = 'Administrators'
    Configuration = ''
    ImportConfigurationFromObject = ''
    ImportConfigurationFromFile = ''
    ImportConfigurationFromString = ''
    IISWebSite = 'Default Web Site'
    WebApplicationAlias = 'ARSAdmin'
    ServiceSelection = ''
    ServiceName = ''
    ConfigurationName = 'ARSAdmin'
    ForceCreateDefaultARWebSite = 'False'

    [2017-10-10T15:44:11.545] [<not set>]: [NewWebSiteAction.Validate]: begin...

    [2017-10-10T15:44:11.545] [<not set>]: [ChangeWebSiteAction.InternalValidate]: begin...

    [2017-10-10T15:44:11.545] [<not set>]: [WebApplicationManager.GetServiceSelection]: Start...

    [2017-10-10T15:44:11.546] [<not set>]: [WebApplicationManager.GetServiceSelection]: End. Service selection 'LocalService', Service name ''

    [2017-10-10T15:44:11.562] [<not set>]: [ChangeWebSiteAction.CheckIISWebSite]: begin...

    [2017-10-10T15:44:11.600] [<not set>]: [ChangeWebSiteAction.CheckIISWebSite]: end.

    [2017-10-10T15:44:11.600] [<not set>]: [WebApplicationManager.GetARWebSites]: begin... iisSiteName = 'Default Web Site', webApplicationAlias = 'ARSAdmin', configurationName = ''

    [2017-10-10T15:44:11.634] [<not set>]: [WebApplicationManager.GetARWebSites]: end. Count = 0

    [2017-10-10T15:44:11.634] [<not set>]: [ConfigurationStorageAD.GetConfiguration]: Start. Configuration name 'ARSAdmin', Version 'ActiveRoles71', require full data 'False'

    [2017-10-10T15:44:11.810] [<not set>]: [ConfigurationStorageAD.GetConfiguration]: Configuration 'ARSAdmin' has been found.

    [2017-10-10T15:44:11.810] [<not set>]: [Error] [ChangeWebSiteAction.InternalValidate]: Parameter: 'ConfigurationName'. Error: Unable to use configuration name 'ARSAdmin' for new configuration because a configuration with this name already exists.

    [2017-10-10T15:44:11.811] [<not set>]: [Error] [ArsConfigActionHelper.ProcessError]: Message 'Unable to use configuration name 'ARSAdmin' for new configuration because a configuration with this name already exists.';
    Parameter name 'ConfigurationName';
    Stack trace:
    at ActiveRoles.Web.Configuration.ChangeWebSiteAction.ValidateNotExistingConfiguration(Boolean validateOnly, String configurationName, IWebSiteConfigurationStorage configurationStorage)
    at ActiveRoles.Web.Configuration.ChangeWebSiteAction.InternalValidate(NewWebSiteParameters parameters, ARWebSite& site, IWebSiteConfigurationStorage& configurationStorage, Boolean isWebAppCreation)

    [2017-10-10T15:44:11.811] [<not set>]: [ChangeWebSiteAction.InternalValidate]: end.

    [2017-10-10T15:44:11.811] [<not set>]: [NewWebSiteAction.Validate]: end.

    [2017-10-10T15:44:11.811] [<not set>]: [NewWebSiteAction.Execute]: Validation ends.

    [2017-10-10T15:44:11.811] [<not set>]: [ArsBaseCommand.WriteValidationErrors]: begin...

    [2017-10-10T15:44:11.811] [<not set>]: [ArsBaseCommand.WriteValidationErrors]: Validation exception: Unable to use configuration name 'ARSAdmin' for new configuration because a configuration with this name already exists.

    [2017-10-10T15:44:11.811] [<not set>]: [ArsBaseCommand.WriteValidationErrors]: end.

    [2017-10-10T15:44:11.811] [<not set>]: [NewARWebSiteCommand.Execute]: Output object:

    [2017-10-10T15:44:11.811] [<not set>]: IISWebSite: Default Web Site
    WebApplicationAlias: ARSAdmin
    ConfigurationName:
    Version: ActiveRoles71
    ServiceSelection: LocalService
    ServiceName:

    [2017-10-10T15:44:11.811] [<not set>]: [NewARWebSiteCommand.Execute]: end.

    [2017-10-10T15:44:11.811] [<not set>]: [ArsBaseCommand.ProcessRecord]: end.

    [2017-10-10T15:44:20.579] [<not set>]: [ArsBaseCommand.ProcessRecord]: begin...

    [2017-10-10T15:44:20.579] [<not set>]: [NewARWebSiteCommand.Execute]: begin...

    [2017-10-10T15:44:20.579] [<not set>]: [NewWebSiteAction.Execute]: Start

    [2017-10-10T15:44:20.579] [<not set>]: [NewWebSiteAction.Execute]: Parameters:
    ValidateOnly = 'True'
    ConfigSelection = 'ValidateOnly'
    Template = 'Administrators'
    Configuration = ''
    ImportConfigurationFromObject = ''
    ImportConfigurationFromFile = ''
    ImportConfigurationFromString = ''
    IISWebSite = 'Default Web Site'
    WebApplicationAlias = 'ARSAdmin'
    ServiceSelection = ''
    ServiceName = ''
    ConfigurationName = 'ARSAdmin2'
    ForceCreateDefaultARWebSite = 'False'

    [2017-10-10T15:44:20.579] [<not set>]: [NewWebSiteAction.Validate]: begin...

    [2017-10-10T15:44:20.579] [<not set>]: [ChangeWebSiteAction.InternalValidate]: begin...

    [2017-10-10T15:44:20.580] [<not set>]: [WebApplicationManager.GetServiceSelection]: Start...

    [2017-10-10T15:44:20.580] [<not set>]: [WebApplicationManager.GetServiceSelection]: End. Service selection 'LocalService', Service name ''

    [2017-10-10T15:44:20.594] [<not set>]: [ChangeWebSiteAction.CheckIISWebSite]: begin...

    [2017-10-10T15:44:20.630] [<not set>]: [ChangeWebSiteAction.CheckIISWebSite]: end.

    [2017-10-10T15:44:20.630] [<not set>]: [WebApplicationManager.GetARWebSites]: begin... iisSiteName = 'Default Web Site', webApplicationAlias = 'ARSAdmin', configurationName = ''

    [2017-10-10T15:44:20.665] [<not set>]: [WebApplicationManager.GetARWebSites]: end. Count = 0

    [2017-10-10T15:44:20.666] [<not set>]: [ConfigurationStorageAD.GetConfiguration]: Start. Configuration name 'ARSAdmin2', Version 'ActiveRoles71', require full data 'False'

    [2017-10-10T15:44:20.757] [<not set>]: [ConfigurationStorageAD.GetConfiguration]: Configuration is not found. ConfigurationName 'ARSAdmin2', Version 'ActiveRoles71'

    [2017-10-10T15:44:20.757] [<not set>]: [ChangeWebSiteAction.InternalValidate]: end.

    [2017-10-10T15:44:20.757] [<not set>]: [NewWebSiteAction.Validate]: end.

    [2017-10-10T15:44:20.758] [<not set>]: [NewWebSiteAction.Execute]: Validation ends.

    [2017-10-10T15:44:20.758] [<not set>]: [ArsBaseCommand.WriteValidationErrors]: begin...

    [2017-10-10T15:44:20.758] [<not set>]: [ArsBaseCommand.WriteValidationErrors]: end.

    [2017-10-10T15:44:20.758] [<not set>]: [NewARWebSiteCommand.Execute]: Output object:

    [2017-10-10T15:44:20.758] [<not set>]: IISWebSite: Default Web Site
    WebApplicationAlias: ARSAdmin
    ConfigurationName: ARSAdmin2
    Version: ActiveRoles71
    ServiceSelection: LocalService
    ServiceName:

    [2017-10-10T15:44:20.758] [<not set>]: [NewARWebSiteCommand.Execute]: end.

    [2017-10-10T15:44:20.758] [<not set>]: [ArsBaseCommand.ProcessRecord]: end.

    [2017-10-10T15:44:20.792] [<not set>]: [ArsBaseCommand.ProcessRecord]: begin...

    [2017-10-10T15:44:20.793] [<not set>]: [NewARWebSiteCommand.Execute]: begin...

    [2017-10-10T15:44:20.793] [<not set>]: [NewWebSiteAction.Execute]: Start

    [2017-10-10T15:44:20.793] [<not set>]: [NewWebSiteAction.Execute]: Parameters:
    ValidateOnly = 'False'
    ConfigSelection = 'Template'
    Template = 'Administrators'
    Configuration = ''
    ImportConfigurationFromObject = ''
    ImportConfigurationFromFile = ''
    ImportConfigurationFromString = ''
    IISWebSite = 'Default Web Site'
    WebApplicationAlias = 'ARSAdmin'
    ServiceSelection = ''
    ServiceName = ''
    ConfigurationName = 'ARSAdmin2'
    ForceCreateDefaultARWebSite = 'False'

    [2017-10-10T15:44:20.793] [<not set>]: [NewWebSiteAction.Validate]: begin...

    [2017-10-10T15:44:20.793] [<not set>]: [ChangeWebSiteAction.InternalValidate]: begin...

    [2017-10-10T15:44:20.793] [<not set>]: [WebApplicationManager.GetServiceSelection]: Start...

    [2017-10-10T15:44:20.794] [<not set>]: [WebApplicationManager.GetServiceSelection]: End. Service selection 'LocalService', Service name ''

    [2017-10-10T15:44:20.807] [<not set>]: [ChangeWebSiteAction.CheckIISWebSite]: begin...

    [2017-10-10T15:44:20.843] [<not set>]: [ChangeWebSiteAction.CheckIISWebSite]: end.

    [2017-10-10T15:44:20.843] [<not set>]: [WebApplicationManager.GetARWebSites]: begin... iisSiteName = 'Default Web Site', webApplicationAlias = 'ARSAdmin', configurationName = ''

    [2017-10-10T15:44:20.879] [<not set>]: [WebApplicationManager.GetARWebSites]: end. Count = 0

    [2017-10-10T15:44:20.879] [<not set>]: [ConfigurationStorageAD.GetConfiguration]: Start. Configuration name 'ARSAdmin2', Version 'ActiveRoles71', require full data 'False'

    [2017-10-10T15:44:20.921] [<not set>]: [ConfigurationStorageAD.GetConfiguration]: Configuration is not found. ConfigurationName 'ARSAdmin2', Version 'ActiveRoles71'

    [2017-10-10T15:44:20.921] [<not set>]: [ChangeWebSiteAction.InternalValidate]: end.

    [2017-10-10T15:44:20.921] [<not set>]: [NewWebSiteAction.Validate]: end.

    [2017-10-10T15:44:20.921] [<not set>]: [WebSiteConfigurationManager.ProcessWebConfiguration]: Begin...

    [2017-10-10T15:44:22.187] [<not set>]: [WebSiteConfigurationManager.ProcessWebConfiguration]: End.

    [2017-10-10T15:44:22.187] [<not set>]: [NewWebSiteAction.Execute]: Configuration storage successfully created

    [2017-10-10T15:44:22.187] [<not set>]: [WebApplicationManager.CreateARWebSite]: begin...

    [2017-10-10T15:44:22.299] [<not set>]: [WebApplicationManager.VerifySettingsXmlAndScriptFiles]: Begin...

    [2017-10-10T15:44:22.299] [<not set>]: [WebApplicationManager.VerifySettingsXmlAndScriptFiles]: end.

    [2017-10-10T15:44:22.300] [<not set>]: [WebApplicationManager.SetWebConfigurationSettings]: begin... sitePath = '/ARSAdmin', configurationName = 'ARSAdmin2'

    [2017-10-10T15:44:22.300] [<not set>]: [WebApplicationManager.GetWebApplicationConfigurationFolder]: begin... applicationPath = '/ARSAdmin'

    [2017-10-10T15:44:22.300] [<not set>]: [WebApplicationManager.GetWebApplicationConfigurationFolder]: end. Application folder = 'E:\Program Files\Dell\Active Roles\7.1\Web\public\Interfaces\ARSAdmin'

    [2017-10-10T15:44:22.312] [<not set>]: [WebApplicationManager.SetWebConfigurationSettings]: end.

    [2017-10-10T15:44:22.318] [<not set>]: [Error] [NewWebSiteAction.Execute]: ARS WI site creation failed: The specified path already exists.

    [2017-10-10T15:44:22.319] [<not set>]: [Error] [ArsBaseCommand.ProcessRecord]: The specified path already exists.

  • In reply to lrigs:

    Hey Lu,

    If you navigate to:

    E:\Program Files\Dell\Active Roles\7.1\Web\public\Interfaces

    Do you see the site name listed there? If so, you can delete it.