Collection not loading on web portal

Hi all,


I'm trying to load a collection on the Employee overview to add a column on the list of the employees.

This collection is a customview.

But it is not loaded.

I tried to to put load collection both in the collection initializer and the  component initializer but not working.



In attach a screenshot


Thanks Mik

  • I assume that the employee logged in has no permissions to see the values in the table.
    Check the permissions in designer and test it with object browser.
  • In reply to Geraldine Hopf:

    Ok the user I tried can't see table rows.
    But ho can I add a permission role to the table? Which is the default one for lookup ( I think is
    Everyone (Lookup)) but in the designer when i set edit permission for this table I can't add new role to the table.
  • In reply to michele.polizio:

    In regards to permission and how to define them, you should take a look at the following video series in YouTube.

  • In reply to Markus Weiss-Ehlers:

    I added the permission to the table and now my user can see the rows from object browser, but I get this error in web designer now:

    Unable to cast object of type 'VI.WebRuntime.VI_StandardWeb.VI_Common_PageDescription' to type 'VI.WebRuntime.VI_StandardWeb.IVI_Common_PageDescription'.

    (2017-10-10 15:25:46)
  • In reply to michele.polizio:

    Ok the error is gone (don't know how) but I have stille 0 entries in my collection from web designer
  • In reply to michele.polizio:

    is it the same component?
    which version?
    new or migrated?
    Are you sure that your web compiled without errors before?
  • In reply to Geraldine Hopf:

    I added in VI_Employee_voerview a collction to the node Collections objecttype my view, in the node initializer of the that collection i put a node loadcollection for the collection created.
    I'm on version 7.1 new
    No errors
  • In reply to michele.polizio:

    When you are working with the ObjectBrowser and WebDesigner are you using the same authentication module?

    For example, when you are using the "Active Directory" authentication module when you are working with the ObjectBrowser, but on the WebPortal you are using the "Active Directory (Role-based)" authentication module, you will not have the same access rights after a successful login. Because the first one uses the DialogUser and the second one uses the role-based permission Groups.

    So, when you check the permissions you have to ensure that you are using the same authentication module for the ObjectBrowser and WebDesigner.

    The next thing that you have to check is that you have read access for each column where you need access to, if one column is missing the complete load will fail without any exception.

    And last but not least you have to ensure that your view have a primary key (UID column). I had the same problem and got this hint from a good old colleague.

    Hope that one of my tips will help you!

  • In reply to Sven Früh-Klima:

    I check permissions on single column and are ok,

    because is a view I made a primary combining to of the foreign key of the view.

    Should I add a single column new primary UID key?

    I'm asking myself if is right  I load it in the right way but I search on the web designer and other collections are loaded in the same way

  • In reply to michele.polizio:

    Another difference between my loadtype and the other that works is that I added a collection to the "module" VI_Employee_overview instead in other exmplae I have in the webdesigner I have table added to table root node in "component" object
  • In reply to michele.polizio:

    Did you Check like Sven and me described earlier?
    Did you debug, if you actually come to the load statement?

    Yes in a module it is called collection in a component it is called table.

    Do you have a Web Designer Training?

  • In reply to Geraldine Hopf:

    Debugging I notice that the load statment is not triggered, the execution stack goes to Initializer but doesn't go inside to execute the load statment both in the collection inizializer and the module initializer. Why?
  • In reply to michele.polizio:

    Can you try loading a different collection, preferably one if the otb tables and see if that loads? Or maybe try loading the person collection which you already have. This will tell us if the issue is in the module somewhere or perhaps something wrong in the view.
  • In reply to kinshasa:

    Also, as Sven mentioned make sure your view has a primary key. This is done in the backend not in Web designer. If you can't take a pk from the tables then you should consider constructing your own pk in the view definition