Failed to enable storage cartridges in Foglight fot virtualization

Hi

Could anyone tell me what is missing or have to be upgraded first ? I have upgraded our Foglight for Virtualizarion EE to newest version and storage patches after that, but after doing that I can't enable some cartridges (newest version or older versions)

Below are some examples:

Missing dependency for Cartridge: SMISStorageAgent-1.4.0 - 1.4.0-201904081144:Managed-Topology-Service-1.0.3 (matches: LATEST)

Missing dependency for Cartridge: PythonAgentSDK-1.0.4 - 1.0.4-201903210329-44:Managed-Topology-Service-1.0.3 (matches: LATEST)

Regards

Aarno Autio
Chief systems specialist
Bank of Finland

  • Hi Aarno,


    Error message you got shows one depended cartridge (Managed-Topology-Service-1.0.3) was not enabled for some reason, that is why upstream cartridge, in this case StorageAgent and PythonAgentSDK) can’t enable.

    Please go to Foglight UI | Administration | Cartridges | Cartridge inventory and enable Managed-Topology-Service-1.0.3



    Please feel free to contact Quest technical support team if this does not work

    Best regards
    -Lee