"Failed To Activate Trigger" error on AIX

Good Morning All,

Our UNIX Admin recently updated our core Netvault server, as well as several client plugins including two AIX boxes; for brevity, let's call the clients Box1 and Box2 which are supposed to be relatively identical.

 

Ever since the Netvault Server was upgraded, Box1 has been returning an error every time it tries to call the Netvault Trigger; however, Box2 has no problems calling the trigger in the same fashion.  To give a light background, these boxes hold a DB2 database and we have a script on the box that runs a native backup on the server and once complete, it calls the Netvault trigger which is supposed to launch the appropriate Netvault job that backs up the Backup image that db2 made and afetrwards, removes the image off the server.

Can someone point me in the right direction on possible logs to check out or things to try, as web search hasn't yielded very much at all regarding the trigger failure.

 

Error: Failed to activate trigger

Trigger Call:  /usr/netvault/bin/nvtrigger -server <netvault server name> <Backup Job Name>

  • Hi,

    So in the above call the "Backup Job Name" should be the trigger name that was entered in the schedule set used for this job. If you look at that job and find the trigger name in the schedule set and attempt to manually run the nvtrigger command does it work fine? You could attempt to run it firstly on the backup server to confirm that the trigger is working fine. If that does work then attempt to run it on the AIX box in question. Is there a password for the admin/default user in NetVault?
  • In reply to gsteel:

    Thanks for the reply...I will try to manually run from the Netvault server. I did try to manually run on client machine, but it failed the same as if the script had called it. The DEFAULT account doesn't have a password when I log into the new web interface to monitor jobs. I'll let you know the results of trying to run on the Backup server versus the client...
  • In reply to chris_barnhart:

    I ran the Trigger command from the Netvault server and the trigger worked fine and started the job...I then took the exact same command and ran it on the problematic client, and again got the message "Failed to activate trigger"
  • In reply to chris_barnhart:

    To clarify, I logged into the Netvault Master server and initiated the trigger on that box and it worked...seems to only fail when initiated from the specific client
  • In reply to chris_barnhart:

    I guess we can try running the trigger that works on client B on the problematic client which should confirm the problem is with that client.

    After the upgrade of the 2 clients can you confirm in the manage clients screen that the problematic client is indeed online etc. Do a check access on it to confirm that there is nothing blocking communication...when the job started when you ran the trigger on the backup server did it complete ok?
  • In reply to gsteel:

    I tried running the Trigger command on client B and it worked fine. The problematic client indeed shows online (and not password protected) and when I perform a "Check Access", it comes back with "System Access Passed". When I invoke the job via trigger from client B or the NV Master server or manually launching the job through the web interface, the job runs successfully.
  • In reply to chris_barnhart:

    Ok....so lets try narrow it down a little more.....the trigger command that is used on client B each day and works....what happens if we run that on the problematic client A. Does it also fail to activate that trigger. Just want to see if its a problem with all triggers from that client.

    What versions of NVBU are we talking about on the backup server and the clients in question?
  • In reply to gsteel:

    I took the NV Trigger command that has been running successfully on Client B and ran it on the problematic Client A and it again failed with messaging of "Failed to activate trigger".

    Both Clients A and B have the same Netvault version and plugins installed.

    From the View Client screen for problematic Client A:
    Netvault Backup Version: 11.2.0.16
    Netvault backup Release: R2016DEC08-v11.2.0.16
    Data Copy Plugin: 11.2.0.7
    CLI: 11.2.0.10

    View Client screen for Master Netvault Server:
    Netvault Backup Version: 11.2.0.15
    Netvault Backup Release: NVBU 11020
  • In reply to chris_barnhart:

    Chris what OS is the NetVault server running. It has to be either windows or Linux and I just checked and the version for either is 11.2.0.16 according to the download site. So wondering why it is .15 on your server. Doubt that is the problem since client B is working fine and that is on .16 as well.

    I have tried to reproduce the error you are getting but have been unable to get that exact message. (have made it fail in other ways). Have you tried restarting the netvault services on the troublesome client just to reset everything?
  • In reply to gsteel:

    OS on netvault master server (uname -a):
    Linux oddcpubck01 2.6.32-642.11.1.el6.x86_64 #1 SMP Wed Oct 26 10:25:23 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux

    I haven't tried restating the NV Client yet...it has been restarted since the issue started occuring though, but I'll try again if you think that will help
  • In reply to chris_barnhart:

    I see the NV services have been up since Jan 23, as I believe the UNIX Admin updated the client plugins that day in an effort to resolve the issue. Are there log files anywhere you;re aware of that may shed more light on the failure?
  • In reply to chris_barnhart:

    Our UNIX Admin opened a Support Ticket and finally resolved this issue. It ended up being some permission issue upon install, so he re-installed the client side with a different UMASK and the trigger activation was successful.