Error with cartridge 5.9.3.20 and MySQL 8.0.14 enterprise

Hi guys,

Has anybody tried to monitor a MySQL 8.0.14 enterprise database with MySQL Agent cartridge version 5.9.3.20?

I'm not having any luck, trying multiple permutations of configuration, including skipping start test.

Generally logs show:

2019-04-12 15:50:32.520 ERROR   [FglAM:IncomingMessage[5]-78] com.sma.mysql.agent.VersionInfo - An unexpected error occurred which may cause undesired behavior. You may want to contact customer support if you see this error again:  Error retrieving server version.

I thought I'd ask here before cutting a support ticket.

Many thanks!

John

Parents
  • Hello John,

    I'm not certain specifically about MySQL 8.0.14, but we have successfully used the MySQL cartridges at other 8.0.x release with 5.9.2.1 and higher cartridge versions.

    If the "Error retrieving server version" followed by a "java.sql.SQLNonTransientConnectionException: CLIENT_PLUGIN_AUTH is required" message then this might indicate an issue with the MySQL connector version in the cartridge and that perhaps an older cartridge is conflicting. In this circumstance I would open a Service Request.

    John

Reply Children
No Data