NetVault

"Failed To Activate Trigger" error on AIX

Good Morning All,

Our UNIX Admin recently updated our core Netvault server, as well as several client plugins including two AIX boxes; for brevity, let's call the clients Box1 and Box2 which are supposed to be relatively identical.

 

Ever since the Netvault Server was upgraded, Box1 has been returning an error every time it tries to call the Netvault Trigger; however, Box2 has no problems calling the trigger in the same fashion.  To give a light background, these boxes hold a DB2 database and we have a script on the box that runs a native backup on the server and once complete, it calls the Netvault trigger which is supposed to launch the appropriate Netvault job that backs up the Backup image that db2 made and afetrwards, removes the image off the server.

Can someone point me in the right direction on possible logs to check out or things to try, as web search hasn't yielded very much at all regarding the trigger failure.

 

Error: Failed to activate trigger

Trigger Call:  /usr/netvault/bin/nvtrigger -server <netvault server name> <Backup Job Name>

  • Hi,

    So in the above call the "Backup Job Name" should be the trigger name that was entered in the schedule set used for this job. If you look at that job and find the trigger name in the schedule set and attempt to manually run the nvtrigger command does it work fine? You could attempt to run it firstly on the backup server to confirm that the trigger is working fine. If that does work then attempt to run it on the AIX box in question. Is there a password for the admin/default user in NetVault?
  • Thanks for the reply...I will try to manually run from the Netvault server. I did try to manually run on client machine, but it failed the same as if the script had called it. The DEFAULT account doesn't have a password when I log into the new web interface to monitor jobs. I'll let you know the results of trying to run on the Backup server versus the client...
  • I ran the Trigger command from the Netvault server and the trigger worked fine and started the job...I then took the exact same command and ran it on the problematic client, and again got the message "Failed to activate trigger"
  • To clarify, I logged into the Netvault Master server and initiated the trigger on that box and it worked...seems to only fail when initiated from the specific client
  • I guess we can try running the trigger that works on client B on the problematic client which should confirm the problem is with that client.

    After the upgrade of the 2 clients can you confirm in the manage clients screen that the problematic client is indeed online etc. Do a check access on it to confirm that there is nothing blocking communication...when the job started when you ran the trigger on the backup server did it complete ok?