Migrator for Notes to SharePoint

Error in XML document - nmsp

Hi, I have 6 jobs that I would like to run through a .bat file.  I used to be able to do this.  

When we upgraded to the latest version, I keep getting the error "Migration Failed: There is an error in XML document (76,5)".  The line number is different for the other job.

However, these jobs all run with no problem when I run them individually through the Migrator designer.

Any thoughts?  Thanks much.

  • Thanks for posting in the Migrator for Notes to SharePoint (MNSP) community forum. I understand that you are running into issues when attempting to run a migration using command line arguments within a batch file. What exact version of MNSP are you currently using (Help | About)?


    I can then try running a test in my lab environment using the same version of MNSP as you.
  • Thanks. We are using 6.9.1.2572.

    We built it using the designer and the jobs run fine through the designer. However, we get the XML error when running the bat file.

    The other weird thing is, which is a separate issue from above, we built a job using the same version of the tool (but the test version only) on one machine and tried running it on the version with a license on another machine. We were unable to open the job and got the XML error as well for this scenario.
  • Thanks for the update. I installed Migrator for Notes to SharePoint (MNSP) version 6.9.1.2572 in my lab environment and was able to migrate from the command-line successfully.

    The following KB article may be related to the issue you are experiencing:

    support.quest.com/.../113915

    In order to investigate further, we would need a copy of the job file you are using and the complete command you are using with arguments. The best way to send in this data, while maintaining privacy, would be to create Service Request:

    support.quest.com/create-service-request
  • We removed this line from the job xml file and we were able to run the job through the command line.

    <ReUpdateMmFieldByCsom>false</ReUpdateMmFieldByCsom>

    However, we got another error:
    Migration Failed: Could not load file or assembly 'Quest.NSP.Transform.Notes' or
    one of its dependencies. The system cannot find the file specified.
  • Thanks for the update. I am glad to hear you were able to get past the first XML error you are experiencing. I understand you are now experiencing a new, "Could not load file or assembly 'Quest.NSP.Transform.Notes'" error.

    1.) Have you tried running the batch file from within a Command Prompt that was created "as Administrator"? Migrator for Notes to SharePoint (MNSP) does rely on third-party APIs, such as the Notes Client API, which can be limited if MNSP is not running with elevated permissions.

    2.) This type of error can also occur when MNSP is unable to launch the Notes Client API. Are you able to launch the Notes Client and connect to the Domino server on the MNSP migration server?

    3.) If you open MNSP Designer | Tools | Options | Notes, is the Notes password set?

    4.) Sometimes there can be errors with MNSP launching the Notes Client API when it is not set as part of the system PATH variable. The following KB article provides more details:

    support.quest.com/.../44056

    Let me know if any of these suggestions help lead to a resolution of the issue you are experiencing.