cannot add restored volume to prtection

I had to do a full restore to the C:\drive of one of my servers, all is back up and well but now I cannot add the resorted volume to protection. I get an "agent does not contain Volume with this id = \\?\Volume{long guid}\" any way to fix this?

  • Hi smabin:
    Probably you have replaced the hardware. As such Rapid Recovery tries to link the old recovery points to the new hard drive and the disk id changed. However, I am not sure why you get a changed volume id -- which I am fairly sure should have been the same. I tried to see if the volume id can be changed.

    Assuming that the volume letter is $volletter = 'R:'
    First I tried to get the volume information:

    get-wmiobject -class win32_volume -filter "DriveType like '3' and DriveLetter like '$volletter'" | select-object driveletter,deviceID

    and I got
    driveletter deviceid
    ----------- --------
    R: \\?\Volume{38d5d023-8c82-4357-906f-741f98a95fef}\

    then I checked to see if the deviceid can be changed

    get-wmiobject -class win32_volume -filter "DriveType like '3' and DriveLetter like '$volletter'" | Get-Member

    for a moment it looked that it might have worked:

    Description Property string Description {get;set;}
    DeviceID Property string DeviceID {get;set;}
    DirtyBitSet Property bool DirtyBitSet {get;set;}

    Looks that the DeviceId can be set.
    I created a random device ID
    $DeviceID = "\\?\Volume{$(([GUID]::NewGuid()).guid)}"

    and attempted to replace it via WMI:
    get-wmiobject -class win32_volume -filter "DriveType like '3' and DriveLetter like '$volletter'" | Set-WmiInstance -Arguments @{DeviceId="$DeviceId"}

    Got an error message:
    Set-WmiInstance : Not supported
    At line:1 char:100
    + ... lletter'" | Set-WmiInstance -Arguments @{DeviceId="\\?\Volume{3ebfea9 ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : InvalidOperation: (:) [Set-WmiInstance], ManagementException
    + FullyQualifiedErrorId : SetWMIManagementException,Microsoft.PowerShell.Commands.SetWmiInstance

    Went to check the documentation (duh) and found that:
    Data type: string
    Access type: Read-only
    Unique identifier for the volume on this system.

    As such it seems that we cannot change the DeviceId.

    These being said, I would suggest the following work around:
    1. On the agent (export first and ) delete the following registry key: HKEY_LOCAL_MACHINE\SOFTWARE\AppRecovery\Agent
    2. Restart the agent service
    3. Reprotect the agent (base images may be needed)

    If you have already upgraded the core to 6.2 it should work without a hitch, despite having the same display name in the recovery points only area and in the protected agents area. With earlier versions of Rapid Recovery you may need to protect using the agent IP address and give it a slightly changed display name (such as [server1-new]). Changing the display name for recovery points only is possible only through the API. At this point, you do not need to upgrade any agent 5.4.3 or newer.