source and target database on the same linux server

I'm setting up replication from a 12.1 oracle database to a 12.1 oracle database using SP 8.6.6.  Both databases are on the same linux server.  I set up the source and started cop via

sp_cop -ukmsd02_2101 &


Then I setup up the target and tried to start cop.  I got this error:  Cop: Address already in use tcp server bind addr port 19576 - exiting  [module cop].

Cop was running when I set up the target.  Is that the problem?  What are the special considerations when replicating on the same server?




  • Hello Karen,

    You don't need 2 different installations of SharePlex when replicating between the DBs of the same version residing on one server. Are these PDBs on 12c?

    Here are the steps involved in configuring SharePlex:

    a. Install SharePlex. You only need one set of binaries for SharePlex.
    b. Run ora_setup once for each instance.
    c. Activate the config and start replication.

    Contact SharePlex support for additional assistance.

    SharePlex Team.
  • Thanks for the quick help! I activated the config. I'm getting an error with post.

    Notice 2017-08-25 11:38:40.680372 923 58828640 User command: oracle start post (from edhlsdbsd001)
    Info 2017-08-25 11:38:40.681826 1390 83548000 Poster launched, pid = 1390 (posting from kmsd02, queue edhlsdbsd001, to kmsd01)
    Warning 2017-08-25 11:38:40.772248 1390 2545157984 Poster: Failed to get Oracle username/password from paramdb (posting from kmsd02, queue edhlsdbsd001, to kmsd01) [module sys]
    Error 2017-08-25 11:38:40.772581 1390 2545157984 Poster: 15002 - Ora_setup has not been run for database "kmsd01". (posting from kmsd02, queue edhlsdbsd001, to kmsd01) [module opo]
    Error 2017-08-25 11:38:40.773165 1390 2545157984 Poster stopped: Internal error encountered; cannot continue (posting from kmsd02, queue edhlsdbsd001, to kmsd01)

    I have run ora_setup for the target database, kmsd01.

    I don't understand how this works with only one cop running. It's only looking at the source (kmsd02) variable directory. How do I get it to look at the target (kmsd01) variable directory?

    oracle@edhlsdbsd001> ckenv

    oracle@edhlsdbsd001> spv

    oracle@edhlsdbsd001> cd data

    oracle@edhlsdbsd001> cat connections.yaml
    password: 579b8585a97755e0
    user: SPLEX

    Even when I set the env for the target (kmsd01) and start post, I get this error.

    When I ran ora_setup for the target, should I have had the source environment variables set because the source and target are on the same server?

  • I opened a support ticket for this issue today.