Exchange database checksum stuck - first try - stuck canceling

Performing the checksum check on the Exchange database(s) has been running for 1 day+.    I have canceled it as it seemed to stop making progress.  I've never run a checksum check before, so I can't say it ever worked.  
I noticed a "Deleting index RPFS" job started about 20 seconds after the checksum started,     that RPFS job was also stuck.. I'm trying to cancel that too.   BOTH the checksum job and RPFS job are now stuck canceling.   Can I just reboot the RR server?  or should I wait. (I've only been waiting about 30min for these jobs to cancel).   
fyi, previous mountablity checks DID work.  just the checksum is a monster job I guess. 
edit; found another post here where the recommendation was to kill core.service.    well, it won't stop!.   I tried services, it didn't stop.  now when I try to kill it says Access Denied.   I'm rebooting server now.    CPU usage stopped when tried to kill it.
edit; predictable, server is stuck trying to rebooting (Please wait for system event notification service).  I'll wait here for a bit.