Change Auditor - Agent Deployment Error

Hi. I have this logged with Support but not getting very far. Hoping someone might have some real world advice. 

So single domain , single forest and i have a single coordinator and this is able to install the agent remotely to all machines that are in the same AD site without issues. 

As soon as i try to install to another site i am getting an error

The installation package could not be opened. Verify that the package exsits and that you can access it, or contact the application vendor to verify that its a valid windows installer package (1619) 

When i look on the server i see the RemoteInstallService.exe and the MSI copy over to c:\windows \temp 

I have been over firewall ports, AV , etc etc but nothing seems to make any difference. Any seen this before? Running version 7.3

Thanks in advance 

  • This is a very generic OS-generated error.  Where are you seeing this?

    Perhaps, more directly - what are the respective logs saying?  I.E. the local Coordinator log and the local agent installation log on the target DC in the other site?

    At the end of the day, if you can't get passed this there is always the option of RDP'ing to the DC and performing a local command line installation.  This might actually be a helpful exercise anyway as it might help you to determine if there is something on that DC that is inhibiting the execution of the MSI.

  • Thanks Johnny. local installs are fine but will 300+ servers its not really a viable option. I assume i would face the same issue when i need to upgrade the client. I have sent the logs off to support and going to go over them myself. 

    I am seeing the error on the machine that i am trying to deploy the agent to. 

  • I understand the impracticality of local installs en masse but have you tried to pull down the agent MSI as I suggested and tried to run it just to see what happens?  As I noted in my initial response, that is an OS generated error so it looks like the OS thinks there is something wrong with the file.  

    FWIW, of late the problems I have seen most often with rolling out the agents come from endpoint protection installed on the DCs.  I know you said that you have checked "AV" but is it possible that there is something else still running that is blocking the execution of the MSI?

  • Hi Johnny. This is not just happening on DC's its happening on any server outside of the same site that the Coordinator is installed in. Local agent installs are fine, The agent installs and connects with no issues at all. 

    There is no AV on the remote server and its still the same issue. 

Reply Children
No Data