Privilege Manager group policy blocking RDP

We deploy some Exchange tools as RemoteApp Programs through an internal website using RDWeb. A user logs into the website, sees the icons for the programs and chooses the one they want to run. It has worked fine until this week. Now if the computer has the Privilege Manager group policy applied to it clicking on the icons has no effect. The icons are active, will highlight when you mouse over them etc but don't respond to clicks any longer. After moving the computer to another OU without the PM policy applied and refreshing group policy, it all works properly again.

Local admin rights have not been removed for the logged in user account. Application discovery doesn't show anything trying to run with elevated privileges when clicking on the icon and I've tried adding a rule to allow Active X elevation for the website. We do not have any programs explicitly black listed in PM, in fact I've added a rule to allow Remote Desktop to run.

Has anyone seen this or similar issues with privilege manager 4.2 and RDP?