TeamViewer Updatesu

Our users are able to run TeamViewer but when they try to update to a newer version it fails. I've tried adding rules in Privilege Manager for the files I can see that the update wants to run. I've also tried to add a Privileged Folder for where the update files are stored when TV downloads them. None of this has worked. When the update is downloaded the user is prompted for administrative credentials and their domain credentials which should be elevated will not work.

Has anyone else worked with this and been able to get it to work properly?


  • Hello scott aday,

    In a case like this, I would review the CSEHostEngine.log from a machine that failed to elevate the application.  
    (C:\ProgramData\Privilege Authority\Logs\CSEHostEngine.log)

    In this log you will see any application that was launched and what Privilege Manager is detecting it as. It will then list all the rules it checks it against. It may be that the detected application is not as it is defined in the rule or some other inconsistency. 

    If any further assistance is needed please Contact Technical Support directly to have a support case opened and we can review your logs and settings.