Foglight - Not Starting

All,

I just installed Foglight on CentOS 5.5 x64, 3gigs, i5, plenty of disk space. I took the typical install for the fms_silent.install except I changed that path to /opt.

Fired it up without error and tracing the Management server log it just sits here -

2013-04-23 14:25:27.046 INFO    [main] com.quest.nitro.startup.StartupConfigLoader - Forge Server starting up using HA Pooled Invoker port: 4446

2013-04-23 14:25:27.046 INFO    [main] com.quest.nitro.startup.StartupConfigLoader - Forge Server starting up using HA JNDI UDP Auto Discovery port: 1102

Selinux is off so is the firewall. Any idea why it won't start?

  • Hi Golan,

    Fantastic this Knowledge Article.

    Now I need a "newba" help, hehehe

    I really don't know what changes I need to do in hosts file !!!

    Here are my actually host:

    [root@foglight etc]# tail hosts

    127.0.0.1  localhost localhost.localdomain localhost4 localhost4.localdomain4

    ::1         localhost localhost.localdomain localhost6 localhost6.localdomain6

    I try this:

    [root@foglight etc]# tail hosts

    127.0.0.1  localhost localhost.localdomain localhost4 localhost4.localdomain4

    127.0.0.1  foglight

    20.10.0.190 foglight

    .... and not work !!!

    What is my mistake ?

    Best Rgds,

  • I think you only want one entry for 'foglight'.  Try

    127.0.0.1  localhost localhost.localdomain localhost4 localhost4.localdomain4

    20.10.0.190 foglight

    If you really want 'foglight' to resolve to the loopback adapter on the local host, use

    127.0.0.1  localhost localhost.localdomain localhost4 localhost4.localdomain4 foglight

    But I think you want one or the other

    Jeff

  • Hi Jeff, thank you so much for this Help.

    I think that now we have another problem. jejejeje

    ===============================================================

    tail ManagementServer_2013-11-08_104647_001.log:

    2013-11-08 10:46:56.048 VERBOSE [main] org.jboss.ha.framework.interfaces.HAPartition.Partitionaecca97c-f85e-4303-8adf-e960fb6dabe7 - Initializing

    2013-11-08 10:46:56.069 VERBOSE [main] STDOUT -

    ---------------------------------------------------------

    GMS: address is 20.10.0.190:36535 (cluster=Partitionaecca97c-f85e-4303-8adf-e960fb6dabe7)

    ---------------------------------------------------------

    [root@foglight logs]# tail ManagementServer_2013-11-08_104647_001.log

            at com.sun.proxy.$Proxy5.deploy(Unknown Source)

            at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:482)

            at org.jboss.system.server.ServerImpl.start(ServerImpl.java:362)

            at com.quest.nitro.startup.FoglightServer.start(FoglightServer.java:335)

            at org.jboss.Main.boot(Main.java:200)

            at org.jboss.Main$1.run(Main.java:508)

            at java.lang.Thread.run(Thread.java:662)

    2013-11-08 10:47:15.020 VERBOSE [Native shutdown hooks] com.quest.common.launcher.ShutdownHook - Running the native shutdown hook

    2013-11-08 10:47:20.000 VERBOSE [native] {external process launcher} stdout: 2013-11-08 10:47:20.000 INFO  [native] Quest Process Runner exiting normally.

    [root@foglight logs]# tail ManagementServer_2013-11-08_104647_001.log

            at com.sun.proxy.$Proxy5.deploy(Unknown Source)

            at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:482)

            at org.jboss.system.server.ServerImpl.start(ServerImpl.java:362)

            at com.quest.nitro.startup.FoglightServer.start(FoglightServer.java:335)

            at org.jboss.Main.boot(Main.java:200)

            at org.jboss.Main$1.run(Main.java:508)

            at java.lang.Thread.run(Thread.java:662)

    2013-11-08 10:47:15.020 VERBOSE [Native shutdown hooks] com.quest.common.launcher.ShutdownHook - Running the native shutdown hook

    2013-11-08 10:47:20.000 VERBOSE [native] {external process launcher} stdout: 2013-11-08 10:47:20.000 INFO  [native] Quest Process Runner exiting normally.

    ===============================================================

    Please help me !!!!

  • It looks like you "tail'd" the management server log twice, but I think there is a gap in infomation between them.  I don't think we are seeing the initial error before the shutdown.

    Jeff

  • Agree with Jeff, we prefer actually uploading the log file (you can zip it and attach it to your post here) than just copy/past.

    We need to see more information (in some cases the warning/error is not just the last lines.

    Golan

  • Hi Guys, I'm really sorry for this.... Actually I read all log file but I lost the error.... Now I read again.... It's my fault. My support team restart one of my VMs and the IP has change (dhcp ).

    Now I need to configure agan the FMS with database. I'm looking for how I'll do it.

    Tks again !!!!!

    Best rgds,

  • Perfect Golan !!!

    I had searched for and found these links, and solved this issue.

    Now I have another (yes, more one) problem. But before get your help I'll search a little more

    Thank you so much (you and Jeff) for help.

    Best Rgds,

    ielo

  • We are happy to help.

    The best with new issues is also to post it as new issues/questions rather than adding to old(er) posts.

    Since different issues have different symptoms it makes them more easily searchable for the greater Foglight users community (where people typically look at the title of the post when they search, rather than reading the full trail of replies).

    Hope it is a smoother ride from now on.

    Golan

  • Great Golan ! I'll open a new issue if I need help again !

    Tks again !!!