Backup does not create for only one database on version 8.9 on a secondary COPY_ONLY

Recently upgraded to version 8.9 on SQL 2016.  Backups are taken on an Availability Group secondary.  One database on the instance does not create a file (upon which the verify fails as there is no file).  There is no error in SQL log or in the Litespeed log until the verify.  The file just isn't there.  I have tried running the Litespeed procedure and get the same result.  A native backup does succeed.

  • Hello,

    I would advise opening a support case, so we can look at your issue in detail.

    But here are a few things to check for

    1. Is the secondary replica readable?
    2. Does the secondary replica fall under any of the excluded types listed in your maintenance plan?
    3. Is this a fast compression backup job?
    4. Review what was selected in the "always on availability group" selection box to check it is correct for the replica in question.

    If none of this helps to ID the problem then please enable maintenance plan debug logging (Please do not select maintenace plan reports as they hold no troubleshooting information), reproduce the issue and open a support case.

    Thanks,
    -Ben-