Support for RHEL 8, CentOS 8 or Rocky Linux 8? Including Rocky Linux 9

Released in May of 2019, when is support for these 2 OS's happening?

CentOS 7 & RHEL 7 become unsupported in 4.5 years and that's the latest you support. Makes things very difficult when we build new machines that are expected to go 5 years out.

For those that have tried. The RHEL 7 agent installs on 8 but can't be loaded into the new 4.18+ kernels.

Parents
  • Just to keep this updated for people. Rapid Recovery now supports RHEL 8 & Rocky Linux 8. I have confirmed it's working on at least 3 of ours right now.

    However as mentioned below that this was going to support RHEL/Rocky 9, the latest Rapid Recovery system requirements do not confirm this. I haven't checked to see if this works.

  • I have been trying to get RR 6.7 to work on Alma 9 but get and error with nbd module.  It seems that RR nbd uses a function that is not in the kernel (anymore?)

    make[2]: Entering directory '/usr/src/kernels/5.14.0-70.17.1.el9_0.x86_64'
    CC [M] /var/lib/dkms/nbd/6.7.0.387/build/nbd.o
    /var/lib/dkms/nbd/6.7.0.387/build/nbd.c: In function ‘nbd_bdev_reset’:
    /var/lib/dkms/nbd/6.7.0.387/build/nbd.c:1237:13: error: implicit declaration of function ‘disk_openers’ [-Werror=implicit-function-declaration]
    1237 | if (disk_openers(nbd->disk) > 1)

  • When running the rapidrecovery-config tool to install the kernel modules it will compile and install the rapidrecovery-vss and nbd module. The rapidrecovery-vss module is used for attaching the volumes and backing up the server and the nbd module is used to mount recovery points directly on the Linux server using local_mount. 
    Alma 9 is not yet fully support, but I do have a test machine with the same kernel. The VSS module compiled successfully and the nbd failed with the same error. The backups are completed successfully and have been stable since I upgraded the kernel to 5.14.0-70. Have you confirmed if the VSS module was installed and tried to add the server on the core?

  • However, make sure you use dkms-3.0.8+. I found if I use the dkms that's on the rapid recovery repository I can't restore. If I use the 3.0.8 from the EPEL I can now restore and it works flawlessly.

    nbd always gives the error on the kernel config even though it works for restoring files.

Reply
  • However, make sure you use dkms-3.0.8+. I found if I use the dkms that's on the rapid recovery repository I can't restore. If I use the 3.0.8 from the EPEL I can now restore and it works flawlessly.

    nbd always gives the error on the kernel config even though it works for restoring files.

Children