Unable to restore a backup created in Azure Australia outside of Australia

I'm unable to restore DB backups that are created in Azure Australia, into SQL Servers that are in Azure US or an internal lab (in the US). The same DBs created using native SQL restore fine.

Please help.

Parents Reply Children
  • Hi, you're working with Paul actually. Jeff is not in our team anymore, but I couldn't change his email address in the profile.

    The version doing the backup and encryption is 8.8. This is happening in AU-Central.

    The restores are being done using version 8.0. They are mostly happening on an internal lab, in the US. I've also tried on Litespeed v8.0 in the Azure US-east region, which failed. Using Litespeed 8.0 to restore a native SQL (2008 R2) backup from AU-Central work fine.

    Below is the error shown by the Litespeed 8.0 console, when trying to load a bkp file created by Litespeed 8.8 in Azure AU-Central.

    In the Select Backup Files dialog (after selecting recovery from disk object), then select the BKP file from the file system. The error says "the operation completed with errors". The details are "LiteSpeed SQL Server could not open the backup file C:\example.bkp. Make sure the backup exists and is not in use". ... to answer the obvious, the file is there and it is not in use.

    So, maybe that's the problem, backups created with 8.8 cannot be restored by 8.0.

  • Hello Paul,

    Yes, LS 8.0  should not be used to restore a backup from LS 8.8.

    As a first step I would recommend upgrading the target server to LS 8.9.5 and try your test again.

    Hope that helps,


  • Yup. that worked. We were just down-level in our dev environment. sorry for the fuss.

  • No problem! Always happy to help!