Mail Enabled Public folders stop receiving e-mail - Two Way Sync to O365


Using QMM 8.14 + Nov 19 fixes, we configured 2 way Public folder sync to O365 Exchange Online


Shortly after running the sync commands as per QMM User guide, the customer reported that e-mail stopped getting delivered to some mail-enabled public folders. 

Normal user e-mail to the public folder was ok. So the issue was related to unauthenticated e-mail (App relay etc..), so looking at the Exchange logs we discovered the error "5.7.1 smtp;550 5.7.1 RESOLVER.RST.AuthRequired"


We suspect this relates to in O365. So it seems that Microsoft may have changed / removed this permission and was then sync`d back to the on-premise environment. (Anonymous)


As per above KB, re-adding the permission to the affected folders resolved the issue, for clarity the fix is below

Add-PublicFolderClientPermission -identity "\MyPublic Folder\Test" -User Anonymous -AccessRights CreateItems

You can also update all mail enabled public folder with the below command as well

Get-PublicFolder -Recurse | where {$_.MailEnabled -eq $true} |Add-PublicFolderClientPermission -User Anonymous -AccessRights CreateItems

  • Use the EAC to mail-enabled or mail-disable a public folder
    Navigate to Public folders > Public folders.

    In the list view, select the public folder that you want to mail-enable or mail-disable.

    In the details pane, under Mail settings, click Enable or Disable.

    A warning box displays asking if you're sure you want to enable or disable email for the public folder. Click Yes to continue.

    Hope This Works,