UDC not immediately showing up in list.

We're still in the trial phase of purchasing Foglight for SQL Server and I've run into an issue using the UDC.


I've created a rather simple UDC just to test it.  Everything passes with green checkmarks, I save my changes and that works fine as well.

But when I go to use my new UDC, it's not in the list.  I've hit the REFRESH icon several times, hit F5 several times, even logged out & in again.  Even tried a different browser!!  Nothing.  My new UDC which was saved successfully is  just not there.

Here's where it get weird.  If I wait till the next day, **BAM!!** my UDC I created yesterday is now there!

Now, I went in Agent Properties --> DB_SQL_SERVER --> DB_SQL_SERVER --> Custom Collection Details  "Enable Custom Collections" from FALSE --> TRUE and that seemed to fix my problem...tempoerarily!!  That worked fine... for 2 days!

Yesterday one of my other DBA's created a new UDC and it did not immediately show up in the list like it did before.  Checked the above settings.  Was still set to TRUE.  That night I restarted the FOGLIGHT service on the server & guess what showed up after I logged in?  Yup, the UDC's that were created that day!!


I'm not sure what's going on but has this happened to anyone else?  If so, how did you get past it?  I'm on the current version of Foglight (v5.7.5.3)  My sales rep is checking with the dev team but thought I'd see what's going on in here to see if anyone else experienced it & what they did to fix it.


Parents Reply Children
No Data